<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
<meta name="Generator" content="Microsoft Exchange Server">
<!-- converted from text --><style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left: #800000 2px solid; } --></style>
</head>
<body>
<div>
<div>Hello,</div>
<div><br>
</div>
<div>When you shared ssh keys for master to slave, did you also do it the other way around - share slave to master?</div>
<div><br>
</div>
<div>I had to do this in my case.</div>
<div><br>
</div>
<div>BR,</div>
<div>D.</div>
<div><br>
</div>
<div><br>
</div>
<div>
<div style="font-size:75%; color:#575757">Sent from Samsung Mobile</div>
</div>
<br>
<br>
<br>
-------- Original message --------<br>
From: Jehan Procaccia <jehan.procaccia@tem-tsp.eu> <br>
Date: <br>
To: Sebastian Cohnen <sebastian.cohnen@gmail.com> <br>
Cc: tsung-users@lists.process-one.net <br>
Subject: Re: [Tsung] Can't start newbeam on host lab (reason: timeout) <br>
<br>
<br>
</div>
<font size="2"><span style="font-size:10pt;">
<div class="PlainText"><br>
I guess the IP adress must be in <ip> </ip> tags<br>
first I tried :<br>
<client host="157.158.44.88"<br>
resulting in:<br>
ERROR: client config: 'host' attribute must be a hostname, not an IP ! <br>
(was "157.158.44.88")<br>
<br>
So now I set<br>
<br>
        <client host="lab.tem-tsp.fr" weight="1" maxusers="600" cpu="1"/><br>
                 <ip value="157.158.44.88"></ip><br>
<br>
<br>
this time tsung start OK, but stills fails on<br>
<br>
<br>
# tail -f tsung_controller@cularo.log<br>
<br>
=INFO REPORT==== 18-Nov-2013::09:35:46 ===<br>
     ts_config_server:(0:<0.89.0>) Can't start newbeam on host <br>
'lab.tem-tsp.fr' (reason: timeout) ! Aborting!<br>
<br>
=ERROR REPORT==== 18-Nov-2013::09:36:14 ===<br>
** State machine ts_launcher terminating<br>
** Last event in was {launch,[],"cularo",now}<br>
** When State == wait<br>
**      Data  == <br>
{launcher,undefined,[],"cularo",undefined,false,0,undefined,<br>
undefined,undefined,undefined,1,undefined}<br>
** Reason for termination =<br>
** {timeout,{gen_server,call,<br>
                         [{global,ts_config_server},<br>
                          {get_client_config,"cularo"},<br>
                          60000]}}<br>
<br>
Any other clues ?<br>
Thanks .<br>
<br>
Le 18/11/2013 09:07, Sebastian Cohnen a écrit :<br>
> Hey Jehan,<br>
><br>
> have you tried to use IP addresses or FQDN instead of host names?<br>
><br>
><br>
> On 15 Nov 2013, at 18:30, Jehan Procaccia wrote:<br>
><br>
>> Hello list<br>
>> this problem of running a distributed tsung test, seems to arise <br>
>> often, but I cannot figure out what's wrong in my case<br>
>> I did managed to share ssh keys between my "master" and "slave" tsung <br>
>> hosts, check /etc/hosts, stopped firewalls, test erl connexion<br>
>> as mentioned in <br>
>> <a href="http://tsung.erlang-projects.org/user_manual/faq.html#can-t-start-distributed-clients-timeout-error">
http://tsung.erlang-projects.org/user_manual/faq.html#can-t-start-distributed-clients-timeout-error</a><br>
>><br>
>> # erl -rsh ssh -sname foo -setcookie mycookie<br>
>> Erlang R14B04 (erts-5.8.5) [source] [64-bit] [smp:4:4] [rq:4] <br>
>> [async-threads:0] [kernel-poll:false]<br>
>><br>
>> Eshell V5.8.5  (abort with ^G)<br>
>> (foo@cularo)1> slave:start(lab,bar,"-setcookie mycookie").<br>
>> {ok,bar@lab}<br>
>><br>
>> up to this point evrything seem OK<br>
>><br>
>> now when I lunch a test on master "cularo" :<br>
>><br>
>> # tsung -f ./tsung-scenario2.xml start<br>
>> Starting Tsung<br>
>> "Log directory is: /root/.tsung/log/20131115-1815"<br>
>><br>
>> with in tsung-scenario2.xml a "lab" tsung "slave"<br>
>> <clients><br>
>>          <client host="cularo" use_controller_vm="true"/><br>
>>          <client host="lab" weight="1" maxusers="600" cpu="1"/><br>
>>  </clients><br>
>><br>
>> the target server of tsung doesn't receive any trafic :-(<br>
>><br>
>> Logs  tsung_controller@cularo.log file shows these errors<br>
>><br>
>> =INFO REPORT==== 15-Nov-2013::18:16:08 ===<br>
>>  ts_config_server:(0:<0.87.0>) Can't start newbeam on host lab <br>
>> (reason: timeout) ! Aborting!<br>
>><br>
>> =ERROR REPORT==== 15-Nov-2013::18:16:36 ===<br>
>> ** State machine ts_launcher terminating<br>
>> ** Last event in was {launch,[],"cularo",now}<br>
>> ** When State == wait<br>
>> **      Data  == <br>
>> {launcher,undefined,[],"cularo",undefined,false,0,undefined,<br>
>> undefined,undefined,undefined,1,undefined}<br>
>> ** Reason for termination =<br>
>> ** {timeout,{gen_server,call,<br>
>>                      [{global,ts_config_server},<br>
>>                       {get_client_config,"cularo"},<br>
>>                       60000]}}<br>
>><br>
>> I run tsung-1.5.0-3.el6.x86_64 on a CentOS release 6.4 (Final)<br>
>><br>
>> why my tsung controller cannot start diributed test on host lab ?<br>
>><br>
>> thanks for your help .<br>
>> _______________________________________________<br>
>> Tsung-users mailing list<br>
>> Tsung-users@lists.process-one.net<br>
>> <a href="https://lists.process-one.net/mailman/listinfo/tsung-users">https://lists.process-one.net/mailman/listinfo/tsung-users</a><br>
<br>
_______________________________________________<br>
Tsung-users mailing list<br>
Tsung-users@lists.process-one.net<br>
<a href="https://lists.process-one.net/mailman/listinfo/tsung-users">https://lists.process-one.net/mailman/listinfo/tsung-users</a><br>
</div>
</span></font>
</body>
</html>