[Tsung] add_to_online: warn, id 1 is not connected, do not add to online

Nick Potapov nick_potapov at hotmail.com
Thu Nov 21 07:44:02 CET 2013


Hi Tsung users!
Did anybody check on how Tsung maintains its table of online\offline users?
I'm seeing a problem with "add_to_online: warn, id 1 is not connected,do not add to online" messages when trying to open\close jabber connections in a loop within the same Tsung session (socket). It seems once close connection's called resulting in next messages "Reset last id (1) because its offline", "connection closed, stay alive (persistent) " and then making a new jabber session and changing presence I'm seeing that everything works fine on ejabberd xmpp server but then Tsung fails to add this user id into its own local online\offline users table throwing message "add_to_online: warn, id 1 is not connected,do not add to online". Once again, xmpp traffic looks legit for second iteration. Any clue how to help Tsung to recognize user (1) as online in subsequent loops within the same session\socket? 

Simplified script version is below.
  <sessions>   <session probability="100" name="jabber-example" type="ts_jabber">
    <transaction name="010_connect_socket">    <request> <jabber type="connect" ack="local"></jabber> </request>    </transaction>
    <thinktime value="1"></thinktime>
    <transaction name="020_authenticate">        <request> <jabber type="auth_sasl" ack="local"/> </request>        <request> <jabber type="connect" ack="local"/> </request>	<request> <jabber type="auth_sasl_bind" ack="local"/> </request>        <request> <jabber type="auth_sasl_session" ack="local"/> </request>   </transaction>
    <thinktime value="2"></thinktime>
    <transaction name="030_presence_initial">  	<request> <jabber type="presence:initial" ack="no_ack"/> </request>    </transaction>
    <thinktime value="2"></thinktime>
   <transaction name="100_close">      <request> <jabber type="close" ack="no_ack"></jabber> </request>    </transaction>    <thinktime value="2"></thinktime>

    <!-- repeat above code in a loop, simplified version -->    <!-- xmpp server respond as usual, xmpp traffic looks legit -->    <!-- Tsung throws "add_to_online: warn, id 1 is not connected,do not add to online" after setting presence call -->

    <transaction name="010_connect_socket">    <request> <jabber type="connect" ack="local"></jabber> </request>    </transaction>
    <thinktime value="1"></thinktime>
    <transaction name="020_authenticate">        <request> <jabber type="auth_sasl" ack="local"/> </request>        <request> <jabber type="connect" ack="local"/> </request>	<request> <jabber type="auth_sasl_bind" ack="local"/> </request>        <request> <jabber type="auth_sasl_session" ack="local"/> </request>   </transaction>
    <thinktime value="2"></thinktime>
    <transaction name="030_presence_initial">  	<request> <jabber type="presence:initial" ack="no_ack"/> </request>    </transaction>
    <thinktime value="2"></thinktime>
   <transaction name="100_close">      <request> <jabber type="close" ack="no_ack"></jabber> </request>    </transaction>    <thinktime value="2"></thinktime>
  </session> </sessions>

Thanks,Nikolai 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.process-one.net/pipermail/tsung-users/attachments/20131120/378af3bf/attachment.html>


More information about the Tsung-users mailing list