[Tsung] Can't start newbeam on host lab (reason: timeout)

Jehan Procaccia jehan.procaccia at tem-tsp.eu
Mon Nov 18 10:39:58 CET 2013


yes I did shared ssh key (with ssh-copy-id) on both sides.

from 'master' cularo
[root at cularo]# ssh root at lab erl -v
Eshell V5.8.5  (abort with ^G)
1>

from 'slave' lab
[root at lab ~]# ssh root at cularo erl -v
Eshell V5.8.5  (abort with ^G)
1>


Le 18/11/2013 10:14, Dragan Pelengič a écrit :
> Hello,
>
> When you shared ssh keys for master to slave, did you also do it the 
> other way around - share slave to master?
>
> I had to do this in my case.
>
> BR,
> D.
>
>
> Sent from Samsung Mobile
>
>
>
> -------- Original message --------
> From: Jehan Procaccia <jehan.procaccia at tem-tsp.eu>
> Date:
> To: Sebastian Cohnen <sebastian.cohnen at gmail.com>
> Cc: tsung-users at lists.process-one.net
> Subject: Re: [Tsung] Can't start newbeam on host lab (reason: timeout)
>
>
>
> I guess the IP adress must be in <ip> </ip> tags
> first I tried :
> <client host="157.158.44.88"
> resulting in:
> ERROR: client config: 'host' attribute must be a hostname, not an IP !
> (was "157.158.44.88")
>
> So now I set
>
>         <client host="lab.tem-tsp.fr" weight="1" maxusers="600" cpu="1"/>
>                  <ip value="157.158.44.88"></ip>
>
>
> this time tsung start OK, but stills fails on
>
>
> # tail -f tsung_controller at cularo.log
>
> =INFO REPORT==== 18-Nov-2013::09:35:46 ===
>      ts_config_server:(0:<0.89.0>) Can't start newbeam on host
> 'lab.tem-tsp.fr' (reason: timeout) ! Aborting!
>
> =ERROR REPORT==== 18-Nov-2013::09:36:14 ===
> ** State machine ts_launcher terminating
> ** Last event in was {launch,[],"cularo",now}
> ** When State == wait
> **      Data  ==
> {launcher,undefined,[],"cularo",undefined,false,0,undefined,
> undefined,undefined,undefined,1,undefined}
> ** Reason for termination =
> ** {timeout,{gen_server,call,
>                          [{global,ts_config_server},
>                           {get_client_config,"cularo"},
>                           60000]}}
>
> Any other clues ?
> Thanks .
>
> Le 18/11/2013 09:07, Sebastian Cohnen a écrit :
> > Hey Jehan,
> >
> > have you tried to use IP addresses or FQDN instead of host names?
> >
> >
> > On 15 Nov 2013, at 18:30, Jehan Procaccia wrote:
> >
> >> Hello list
> >> this problem of running a distributed tsung test, seems to arise
> >> often, but I cannot figure out what's wrong in my case
> >> I did managed to share ssh keys between my "master" and "slave" tsung
> >> hosts, check /etc/hosts, stopped firewalls, test erl connexion
> >> as mentioned in
> >> 
> http://tsung.erlang-projects.org/user_manual/faq.html#can-t-start-distributed-clients-timeout-error
> >>
> >> # erl -rsh ssh -sname foo -setcookie mycookie
> >> Erlang R14B04 (erts-5.8.5) [source] [64-bit] [smp:4:4] [rq:4]
> >> [async-threads:0] [kernel-poll:false]
> >>
> >> Eshell V5.8.5  (abort with ^G)
> >> (foo at cularo)1> slave:start(lab,bar,"-setcookie mycookie").
> >> {ok,bar at lab}
> >>
> >> up to this point evrything seem OK
> >>
> >> now when I lunch a test on master "cularo" :
> >>
> >> # tsung -f ./tsung-scenario2.xml start
> >> Starting Tsung
> >> "Log directory is: /root/.tsung/log/20131115-1815"
> >>
> >> with in tsung-scenario2.xml a "lab" tsung "slave"
> >> <clients>
> >>          <client host="cularo" use_controller_vm="true"/>
> >>          <client host="lab" weight="1" maxusers="600" cpu="1"/>
> >>  </clients>
> >>
> >> the target server of tsung doesn't receive any trafic :-(
> >>
> >> Logs  tsung_controller at cularo.log file shows these errors
> >>
> >> =INFO REPORT==== 15-Nov-2013::18:16:08 ===
> >>  ts_config_server:(0:<0.87.0>) Can't start newbeam on host lab
> >> (reason: timeout) ! Aborting!
> >>
> >> =ERROR REPORT==== 15-Nov-2013::18:16:36 ===
> >> ** State machine ts_launcher terminating
> >> ** Last event in was {launch,[],"cularo",now}
> >> ** When State == wait
> >> **      Data  ==
> >> {launcher,undefined,[],"cularo",undefined,false,0,undefined,
> >> undefined,undefined,undefined,1,undefined}
> >> ** Reason for termination =
> >> ** {timeout,{gen_server,call,
> >>                      [{global,ts_config_server},
> >>                       {get_client_config,"cularo"},
> >>                       60000]}}
> >>
> >> I run tsung-1.5.0-3.el6.x86_64 on a CentOS release 6.4 (Final)
> >>
> >> why my tsung controller cannot start diributed test on host lab ?
> >>
> >> thanks for your help .
> >> _______________________________________________
> >> Tsung-users mailing list
> >> Tsung-users at lists.process-one.net
> >> https://lists.process-one.net/mailman/listinfo/tsung-users
>
> _______________________________________________
> Tsung-users mailing list
> Tsung-users at lists.process-one.net
> https://lists.process-one.net/mailman/listinfo/tsung-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.process-one.net/pipermail/tsung-users/attachments/20131118/269514af/attachment-0001.html>


More information about the Tsung-users mailing list