[Tsung] Can't start newbeam on host lab (reason: timeout)

Sebastian Cohnen sebastian.cohnen at gmail.com
Mon Nov 18 09:07:00 CET 2013


Hey Jehan,

have you tried to use IP addresses or FQDN instead of host names?


On 15 Nov 2013, at 18:30, Jehan Procaccia wrote:

> Hello list
> this problem of running a distributed tsung test, seems to arise 
> often, but I cannot figure out what's wrong in my case
> I did managed to share ssh keys between my "master" and "slave" tsung 
> hosts, check /etc/hosts, stopped firewalls, test erl connexion
> as mentioned in 
> http://tsung.erlang-projects.org/user_manual/faq.html#can-t-start-distributed-clients-timeout-error
>
> # erl -rsh ssh -sname foo -setcookie mycookie
> Erlang R14B04 (erts-5.8.5) [source] [64-bit] [smp:4:4] [rq:4] 
> [async-threads:0] [kernel-poll:false]
>
> Eshell V5.8.5  (abort with ^G)
> (foo at cularo)1> slave:start(lab,bar,"-setcookie mycookie").
> {ok,bar at lab}
>
> up to this point evrything seem OK
>
> now when I lunch a test on master "cularo" :
>
> # tsung -f ./tsung-scenario2.xml start
> Starting Tsung
> "Log directory is: /root/.tsung/log/20131115-1815"
>
> with in tsung-scenario2.xml a "lab" tsung "slave"
> <clients>
>          <client host="cularo" use_controller_vm="true"/>
>          <client host="lab" weight="1" maxusers="600" cpu="1"/>
>  </clients>
>
> the target server of tsung doesn't receive any trafic :-(
>
> Logs  tsung_controller at cularo.log file shows these errors
>
> =INFO REPORT==== 15-Nov-2013::18:16:08 ===
>  ts_config_server:(0:<0.87.0>) Can't start newbeam on host lab 
> (reason: timeout) ! Aborting!
>
> =ERROR REPORT==== 15-Nov-2013::18:16:36 ===
> ** State machine ts_launcher terminating
> ** Last event in was {launch,[],"cularo",now}
> ** When State == wait
> **      Data  == 
> {launcher,undefined,[],"cularo",undefined,false,0,undefined,
> undefined,undefined,undefined,1,undefined}
> ** Reason for termination =
> ** {timeout,{gen_server,call,
>                      [{global,ts_config_server},
>                       {get_client_config,"cularo"},
>                       60000]}}
>
> I run tsung-1.5.0-3.el6.x86_64 on a CentOS release 6.4 (Final)
>
> why my tsung controller cannot start diributed test on host lab ?
>
> thanks for your help .
> _______________________________________________
> Tsung-users mailing list
> Tsung-users at lists.process-one.net
> https://lists.process-one.net/mailman/listinfo/tsung-users


More information about the Tsung-users mailing list